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Motor-CAD Software Tutorial:  

Modelling the Nissan Leaf Motor using Motor-CAD 
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1. Description 
The brushless permanent magnet (BPM) machine of the 2012 Nissan LEAF is modelled in 

Motor-CAD. We obtain detailed electromagnetic and thermal performance results for a single 

operating point, efficiency maps showing the performance across the full operating range and 

combined electromagnetic and thermal performance for a complex drive cycle. 

The model information, hardware images and performance test data have been drawn from 

the following reports: 

• Tim Burress, “Benchmarking of Competitive Technologies”, Oak Ridge National 

Laboratory, May 2012. 

http://energy.gov/sites/prod/files/2014/03/f10/ape006_burress_2012_p.pdf  

• Tim Burress, “Benchmarking State-of-the-Art Technologies”, Oak Ridge National 

Laboratory, May 2013. 

http://energy.gov/sites/prod/files/2014/03/f13/ape006_burress_2013_o.pdf  

• “Annual Progress Report Advanced Power Electronics and Electric Motors 

Program” Vehicle Technologies Program, U.S Department of Energy. January 

2013.  

• Susan A. Rogers, “Annual Progress Report for the Advanced Power Electronics 

and Electric Motors Program” Vehicle Technologies Program, U.S Department of 

Energy. December 2013.  

http://energy.gov/sites/prod/files/2014/04/f15/2013_apeem_report.pdf 

• John M.Miller, “Electric Motor R&D”, Oak Ridge National Laboratory, May 2013. 

http://energy.gov/sites/prod/files/2014/03/f13/ape051_miller_2013_o.pdf  

• Yoshinori Sato, Shigeaki Ishikawa, Takahito Okubo, Makoto Abe, and Katsunori 

Tamai, ―Development of High Response Motor and Inverter System for the 

Nissan LEAF Electric Vehicle,‖ International World Congress and Exhibition, 

Detroit, Michigan, April 12–14, 2011, paper 2011-01-0350. 

  

 

 

http://energy.gov/sites/prod/files/2014/03/f10/ape006_burress_2012_p.pdf
http://energy.gov/sites/prod/files/2014/03/f13/ape006_burress_2013_o.pdf
http://energy.gov/sites/prod/files/2014/04/f15/2013_apeem_report.pdf
http://energy.gov/sites/prod/files/2014/03/f13/ape051_miller_2013_o.pdf
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2. Starting Motor-CAD 
Install Motor-CAD on the computer by launching the Motor-CAD_Setup.exe (file name will 

depend on the version selected) and following the instructions. The recommended version of 

Motor-CAD for this tutorial is v11.1. 

When the installation is finished, run Motor-CAD and it will start with a default brushless 

permanent magnet synchronous machine. 

We will start by configuring the electromagnetic model. Select Model -> E-Magnetic from the 

main menu to show the electromagnetic context (tip: a blue background on the active tab 

indicates electromagnetic context). 

 

Select File -> Save As… to save the file as Nissan_LEAF_1_Geometry.mot in the desired 

location. 
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i. Motor-CAD Manual 

There is a comprehensive manual included with Motor-CAD which can be accessed at any 

time by selecting Help -> Manual from the main menu, or pressing F1. 
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ii. Default Units 

Motor-CAD allows users to select different units to use for the input/output parameters. For 

this tutorial we will be working mostly in SI units. 

Open the Units dialog from Defaults -> Units, and set the units as shown below: 
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3. Electromagnetic Model 
The following main tabs are available in the E-Magnetic context for sine-wave driven BPM 

machines. Generally in Motor-CAD we work through the tabs from left to right in order to set 

up the model, run the calculations and analyse the results. 

Tab Description 

Geometry Define & view the machine geometry (radial, axial, 3d) 

Winding Define & view the stator winding (winding pattern, conductors) 

Input Data Specify materials used in the model, adjust advanced settings 
(calculation methods, FEA settings, build factors, etc) 

Calculation Specify the operating point & run the calculations 

E-Magnetics E-Magnetic 2D FEA – view results, customise FEA geometry, 
measure quantities, design optimisation 

Output Data View numerical results (from FEA and analytic calculations) 

Graphs View results waveforms from transient simulations 

Sensitivity Sensitivity analysis - vary input parameters and analyse effect 
on machine performance 

Scripting Create & run Visual Basic scripts in Motor-CAD 
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i. Geometry Inputs 

The Geometry tab in Motor-CAD is used to define the machine geometry using the Axial and 

Radial views. In the electromagnetic context, only parameters that are considered in the 

electromagnetic model are displayed and so some machine components (e.g. housing, 

mounting etc) are hidden. 

In the Geometry -> Radial tab, we set the radial geometry of the stator as follows: 

Stator Parameter Value Units 

Slot Type Parallel Tooth 
 

Stator Ducts None 
 

Slot Number 48  

Stator Lam Dia 198 mm 

Stator Bore 132 mm 

Tooth Width 4.15 mm 

Slot Depth 21.1 mm 

Slot Corner Radius 2 mm 

Tooth Tip Depth 1.2 mm 

Slot Opening 2.814 mm 

Tooth Tip Angle 27 degrees 

Sleeve Thickness 0 mm 

 

After editing parameters, press Enter or click the Redraw button to update the drawing. As 

the tables are edited, green highlighting shows which values have been changed. 
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We set up the rotor magnet geometry by changing the following parameters: 

Rotor Parameter Value Units 

Rotor Type Interior V (web)  

Pole Number 8  

Notch Depth   

Magnet Layers 2  

L1 Magnet Thickness 3.862 mm 

L1 Magnet Bar Width 13.9 mm 

L1 Bridge Thickness 0.6 mm 

L1 Web Thickness 21 mm 

L1 Web Length 0 mm 

L1 Pole V Angle 180 degrees 

L1 Pole Arc 150 degrees 

L2 Magnet Thickness 2.6 mm 

L2 Magnet Bar Width 21.33  

L2 Bridge Thickness 7.65 mm 

L2 Web Thickness 2.5 mm 

L2 Web Length 0 mm 

L2 Pole V Angle 124 degrees 

L2 Pole Arc 159 degrees 

Airgap 1 mm 

Shaft Dia 44.45 mm 
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Here we also define the cooling ducts in the rotor. These are considered in the electromagnetic 

model since the presence of ducts in the rotor iron will change the electromagnetic behaviour 

of the motor. 

Rotor Parameter Value Units 

Rotor Ducts Circular Ducts  

Rotor Duct Layers 2  

L1 RDuct Rad Dia 63.94 mm 

L1 RDuct Channel 8  

L1 RDuct Dia 9.88 mm 

L1 RDuct Angle 0 degrees 

L2 RDuct Rad Dia 124 mm 

L2 RDuct Channel 8  

L2 RDuct Dia 5.1 mm 

L2 RDuct Angle 22.5 mm 

 

 

Now save the file using File -> Save or Ctrl+S. 
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In the Geometry -> Axial tab we set the axial dimensions of the motor: 

Axial Parameter Value Units 

Motor Length 260 mm 

Stator Lam Length 160 mm 

Magnet Length 150 mm 

Magnet Segments 18  

Rotor Lam Length 150 mm 

 

Again, press Enter or click Redraw to update the drawing. 

 

The geometry definition for the electromagnetic analysis is now complete and the changes 

can be saved using File -> Save or Ctrl+S. 
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The Geometry -> 3D tab shows a 3D view of the motor to allow visualisation of the machine. 

Transparency levels of components can be set by right-clicking them in the component list. 

Components or groups of components can also be hidden by deselecting checkboxes in the 

list. 
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ii. Winding Definition 

Now that the geometry is defined, we use the Winding tab to define the conductors and 

insulation inside the stator slots. The Definition tab is used to define and visualise the position 

of the conductors with the insulation, impregnation, liner and wedge, making it easy to test 

and check different winding configurations. The Pattern tab provides quick configuration and 

visualisation of the winding layout with the connection of the coils, as well as analysis of the 

phasors, winding factors and harmonic content. 

Winding Pattern 

The electromagnetic winding definition starts with the configuration of the coils, their 

connection and the type of winding used in the design. Under Winding -> Pattern, set the 

following: 

Parameter Value 

Winding Type Automatic 

Path Type Central 

Winding Layers Single Layer 

Phases 3 

Turns 6 

Throw 5 

Parallel Paths 2 

 

Motor-CAD will automatically generate an optimal winding pattern based on the specified 

throw as shown below: 
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By selecting the Phasors tab, we can check that the phasors are 120° apart with equal lengths. 

 

Harmonic Analysis 

Before any simulations are performed, mechanical MMF harmonics and winding factors are 

analysed analytically based on the winding pattern. Under Winding -> Pattern, we can check 

these values under the Harmonics and Factors tabs. 
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Conductor Definition 

Now navigate to the Winding -> Definition tab. Here, the number of conductors in the slot is 

defined by the coil configuration and the number of strands in hand. We have 6 turns per coil, 

with a single coil in each and 1 strand in hand slot so we have 6 x 1 x 1 = 6 conductors/slot. 
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Now define the conductors with the following settings. Note that we have an overlapping 

winding since this design uses a distributed winding pattern. 

Parameter Value Units 

Winding Type Overlapping  

Winding Definition Wire Size  

Wedge Model Wedge  

Wire Type Metric Table  

Wire Gauge [0.885mm, 0.800mm]  

Liner Thickness 0.25 mm 

Copper Depth 100 % 

Conductor Separation 0.02 mm 

Number Strands in Hand 20  

We can verify that the winding is specified correctly by checking that we have 120 

Conductors/Slot and the Copper Slot Fill is approximately 52%. 

(Tip: The Conductors/Slot Drawn parameter will be highlighted in red if the required number 

of conductors cannot fit into the defined slot.) 

Again, save the file with the changes. 
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iii. Materials Input 

The next step is to configure the materials used in the motor, in particular the magnetic steel 

and magnets. 

Materials Database 

Motor-CAD provides a database of materials, which can be viewed under Input Data -> 

Material database. The default database contains full details of many commonly used 

materials. The user can then add details for any materials not included by default. The 

materials currently used in the model are highlighted in yellow in the interface. 

The LEAF motor uses the 30DH steel, which is not included in the default database of 

materials supplied with Motor-CAD. We will therefore have to add the material data to the 

database from the manufacturer’s specifications. 

To add a new material, click the Add Solid button. 

 

In the dialog that appears we type the name, set the Solid type to Steel and click Add. 
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The new material is added to the database and can be viewed in the alphabetical list. We now 

enter the material properties. Under the Physical tab we set: 

Property Value Units 

Thermal Conductivity 30 W/m/C 

Specific Heat 460 J/kg/C 

Density 7650 kg/m3 
 

 

Notes can also be added to the material. 

The electrical properties are configured under the Electrical tab. Before editing the values we 

check that the new material 30DH is selected in the list on the left. We can use the Materials 

Filter to display only Steel materials, making it easier to locate and select the correct material. 

Property Value Units 

Resistivity 5.9E-7 Ohm 

Temperature coefficient 
of resistivity 

1.3 /C 
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The magnetic properties of the steel are configured in the Steel BH tab. Here we enter the BH 

curve data into the table. 

Note that the units must be correct for the data we enter. If the manufacturer provides data in 

alternative units, the data can either be converted before entering into Motor-CAD, or the 

default units in Motor-CAD can be modified by selecting Defaults -> Units from the main menu 

to allow entering of data using alternative units 

For this example, we already have the data in the correct SI units. Copy the B and H values 

(without header row) from the file 30DH Steel.xslx and then paste the data to the table using 

the Insert Data Points button or selecting the first data cell and using Ctrl+V. The graph on 

the right hand side will then update to reflect the data we have added. 
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In addition to the manufacturer’s data, Motor-CAD can estimate further BH points beyond the 

maximum values of the experimental data typically available. Select the Enable 

Extrapolation option to enable this functionality. Enter a maximum H value which will give a 

good safety margin for the expected flux density values in the simulation, and select the 

number of points to provide a good set of data. In this case, the following values are 

appropriate: 

Parameter Value Units 

Max H Value 1000000 Amps/m 

Extrapolation Points 10  

Now click Extrapolate and the points are added to the graph and table. Note that the 

extrapolated values are shown in blue in the table to distinguish from the experimental data, 

and a vertical blue dotted line on the graph indicates the limit of the experimental data. Also 

note that the experimental BH values cannot be edited while extrapolation is enabled. 
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Now we define the iron loss properties of the steel under the Steel Losses data. 

In Motor-CAD, iron losses are calculated based on loss coefficients, using either the Bertotti 

or Modified Steinmetz method. The Steinmetz method is used by default; advanced users can 

select the Bertotti method if required under the Input Data -> Settings -> Losses tab. Further 

information on iron loss calculation methods is provided in the Motor-CAD manual. 

The loss coefficients can be entered manually in the Steel Properties tab, or these 

coefficients can be estimated by Motor-CAD based on experimental values of power loss 

density at different frequencies and flux densities. Since we have loss data available for the 

30DH steel, we will enter the experimental values under the Losses tab. 

 

 

 

Once again, copy the loss data from the file 30DH Steel.xlsx (frequency, loss density and B 

values). Under the Losses tab, paste the data to the table using Insert Data Points or 

selecting the first row in the table and using Ctrl+V. Click Update Graph to update the graph 

with the new data. 



 
 
 
 

 Page 23 of 132 

 

 

 

We will now calculate the loss coefficients from the experimental data using Motor-CAD. Click 

on the Find Coefficients button. This uses an iterative curve fitting method to find the iron 

loss coefficients that best fit the data. This may take several minutes; the progress of the curve 

fitting is shown in the status bar at the bottom of the Motor-CAD window. 
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After the curve fitting is complete, additional curves will be displayed on the chart to show the 

loss models using the calculated coefficients. If we are happy that the potential models match 

the data well, we select Update Database Values to store the calculated coefficients to the 

database. 
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The coefficients calculated can be seen in the Steel Properties tab.  

Note that the minor loop hysteresis loss coefficient is set to 0.65. This is an empirical value 

which cannot be calculated and is neglected when extracting other loss coefficients. The 

default value of 0.65 is chosen based on previous studies and can be edited by the user. Also 

note that there may be minor differences in the calculated coefficients due to the iterative 

nature of the calculation. 

We also need to specify the lamination thickness of the steel. For the 30DH steel we set: 

Parameter Value Units 

Lamination thickness 0.3 mm 

 

 

This completes the process of adding the new steel to the materials database. When saving 

the .mot file, all data relating to the materials used in the model will be contained in the file. In 

addition, the materials database file can be shared to allow organisations to work from a 

standard set of materials. 
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Assigning Component Materials 

We now select the materials used for each component in the Motor-CAD model under the 

Input Data -> Materials tab. We select the following materials using the material dropdowns: 

Component Material 

Stator Lam 30DH 

Stator Winding Copper (Pure) 

Rotor Lam 30DH 

Magnet N30UH 

 

The Copper and N30UH materials are already defined in the default Motor-CAD materials 

database. 

Note that, in the electromagnetic model, some components must use the same material, for 

example the Stator Lam (Back Iron) and Stator Lam (Tooth). This is because the 

electromagnetic model simulates these components together in a single region. Later, in the 

thermal context, we will see that it is possible to specify different materials for these 

components for the thermal model only. 

This table also shows the calculated weights of all the components in the electromagnetic 

design. We can check the total weight to ensure that the geometry and materials have been 

set up correctly. 



 
 
 
 

 Page 27 of 132 

 

 

Now save the file again with File -> Save or Ctrl+S.  
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4. Electromagnetic Analysis 
The E-Magnetic module in Motor-CAD allows 2D FEA electromagnetic analysis and loss 

calculation to obtain the working conditions and performance of the machine. It also has an 

automatic link to the thermal model in Motor-CAD for subsequent thermal analysis. 

Save the file as Nissan_LEAF_2_Electromagnetic.mot. 

i. FEA Simulations in Motor-CAD 

The Calculation tab is where the operating conditions and simulations to run are selected. 

There are many different electromagnetic FEA calculations which can be performed in Motor-

CAD. For a detailed description of the performance tests available, please refer to the Motor-

CAD manual. 

On the left part of the tab we specify the operating conditions for the tests: shaft speed, current, 

phase advance (for on load tests) and DC bus voltage. The voltage specified here is used to 

find the voltage available to the motor from the DC bus. During operation this is compared to 

the voltage required by the motor and a warning is given if there is insufficient voltage 

available.  

Note that the Motor-CAD E-Magnetic module will not limit the operating point to within the 

voltage limit. It will give a warning and then it is up to the user to modify the operating point or 

increase the DC bus voltage.  

The winding temperature is used to calculate the electrical resistance of the winding from the 

dimensions and the winding configuration. The magnet temperature defines the remanence 

of the magnets from the thermal coefficient in the materials database. For more details on 

these calculations, please refer to the Motor-CAD manual. 

The E-Magnetics – Thermal coupling options allow the user to transfer data between Motor-

CAD’s E-Magnetic and Thermal modules. The losses calculated in the e-magnetic solution 

can be passed to the thermal module and machine temperatures from the solved thermal 

model can be passed to the e-magnetic module for more accurate performance and loss 

calculations. These values can be transferred in either direction as a single step or Motor-CAD 

can iteratively solve the e-magnetic and thermal models together until the power losses and 

temperatures converge. 

We can also specify the drive mode, winding connection, magnetisation direction of the 

magnets, and stator or rotor skew. 
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We set the following operating conditions: 

Parameter Value Units 

Shaft Speed 3000 RPM 

Line Current Definition Peak  

Peak Current 480 A 

DC Bus Voltage 375 V 

Phase Advance 45 Elec deg 

 

We also set the drive, connection and magnetisation options: 

Parameter Value Units 

Drive Mode Sine  

Winding Connection Star Connection  

Magnetisation Parallel  

 

At this point we will use a rough estimate of the magnet and stator winding temperatures. 

These temperatures can significantly affect the performance of the machine, so it is best to 

give an estimate here. The other component temperatures are not so crucial so we will leave 

these at their default values. We can get a good first estimate of the machine behaviour using 

these values and then refine the model later based on the thermal calculations. Set the 

following: 

Parameter Value Units 

Stator Winding Temperature 65 °C 

Magnet Temperature 65 °C 
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All the performance tests except for the Back EMF, Cogging Torque and Torque calculations 

should be disabled. The simulation is then run by clicking the Solve E-Magnetic Model button. 

The simulation should complete within 1 minute. 
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ii. Results 

FEA Plots 

The E-Magnetics -> FEA tab shows the FEA geometry, mesh and results while simulations 

are being solved, and after the solution is completed. 

 

 

A separate results file is generated for each calculation, including the single operating points 

that are always simulated regardless of the performance tests selected by the users. The 

results for each calculation can be viewed by selecting the results file from the dropdown list 

in the left hand pane as highlighted above. 
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The results available will depend on which performance tests have been run, and also on more 

advanced simulation settings e.g. magnetic solver type. For this example, we have the 

following result files to choose from: 

File Description 

Cogging Cogging Torque calculation 

On Load Torque On load transient torque (Torque 
calculation) 

On Load Loss Loss calculation from on load transient 
torque (Torque calculation) 

Static OC Single point no load (Q Axis current 
calculation – always performed) 

Open Circuit Transient Open circuit transient (Back EMF 
calculation) 

Open Circuit Loss Loss calculation from open circuit 
transient (Back EMF calculation) 

Static Load Single point on load (On Load calculation – 
always performed) 
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Select OnLoadTorque_result_1.mes from the dropdown to view the results from the 

transient torque simulation. The Shading options now allow us to choose the quantity that is 

displayed on the FEA plot, alternatively different quantities can be selected from the Shading 

function dropdown. Select Flux Density to view the flux in the machine.  

For each time step during the transient simulation we have a different flux plot. We can view 

the results at particular time steps by selecting the time or step number from the dropdown 

menu or use the Play all button to view an animation of the flux over time. The plot can also 

be customised with the Options settings.  

When the mouse is hovered over the plot, detailed information about the point under the 

mouse cursor is shown in the status bar. This includes the region name, flux density, 

permeability, and region area. 
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It can also be useful to visualise the losses in the machine. From the file dropdown, select 

OnLoadLoss_result_1.mes to open the loss results from the transient torque calculation. 

Note that there are no time step controls available since the losses are calculated over the full 

electrical cycle. Here we can use the Shading option to view different types of loss. For 

example, by selecting Eddy Loss (solid) we can see the distribution of eddy current losses 

in the magnets, noticing that the losses are concentrated in the magnet corners and so these 

areas could be prone to thermal hotspots. 

 

Note that previously calculated flux plots can also be loaded into the FEA viewer using the 

Open button. 
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Output Data Sheets 

The Output Data sheets provide detailed numerical information on the machine showing 

many different parameters calculated by Motor-CAD. For further information on any of the 

output parameters, please refer to the Motor-CAD manual. 
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Graphs 

The resulting waveforms from the simulation can be viewed in the Graphs tab. 
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We can also check the harmonic analysis of the waveforms under Graphs -> Harmonics. 

Note the characteristic 6th and 12th harmonics in the torque waveform. 
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Custom Graphs 

In addition to the graph shown in the Graphs tab, many other quantities are calculated and 

saved by Motor-CAD during the simulation. Under Help -> Graph Viewer there is a graph 

viewer available where the user can view any of these graphs. Multiple series can be plotted 

on a single graph. Using the in-built Graph Editor the user can customise the graphs as well 

as copying the data for use in an external application. For more information please refer to the 

Motor-CAD manual. 
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5. Efficiency Maps and Drive Cycle Analysis with Motor-CAD Lab 
Motor-CAD’s Lab module allows us to quickly and accurately calculate the machine 

performance over the full operational envelope. We can create efficiency maps, study the 

thermally constrained operational envelope, and analyse performance over complex driving 

cycles. 

The Lab module uses a hybrid model that combines the accuracy of FEA calculations with the 

speed of analytic results. We first build the Lab model, performing a series of FEA simulations 

to fully characterise the saturation and loss behaviour of the machine. Once this model build 

is complete we use it to accurately calculate the machine performance with analytic methods. 

Switch to the Lab context using Model -> Lab from the main menu (tip: a green background 

on the active tab indicates Lab context). 

 

As this is the first time we have viewed the Lab context a single static FEA calculation will be 

performed to characterise the fixed inductance performance of the machine at a single rotor 

position. The results can be seen in the Fixed Inductance Model section of the interface.  

The following tabs are available in the Lab context: 

Tab Description 

Model Build Configure & build the Lab model 

Calculation Specify operating conditions, build factors, mechanical 
losses, model scaling 

Electromagnetic Calculation of peak torque/speed curves and 2d maps of 
electromagnetic performance 

Thermal Calculation of machine performance within thermal limits 

Duty Cycle Calculation of machine performance over a driving cycle 

Operating Point Calculation at a single operating point 

Calibration Calculation of performance during open circuit/short circuit 
tests 

Settings Advanced settings & options 

 

Save the Motor-CAD file as Nissan_LEAF_3_Lab_TorqueSpeed.mot. 
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i. Peak Torque/Speed Estimation 

We will use the Lab module to calculate a peak torque/speed curve.  

The Lab model must be built before any calculations can be performed. On the Model Build 

-> Model Options page, we set the following: 

Parameter Value Units 

Model Type Saturation Model (Single Step)  

Model Resolution Coarse  

Loss Model Neglect  

Maximum Speed 10000 rpm 

Max Stator Current (Peak) 480 A 

 

The Saturation Model options are explained below: 

• Fixed Inductance – assumes a constant value of inductance across the full operating 

range. No saturation model build required. 

• Saturation Model (Single Step) – characterises the machine saturation with static FEA 

simulations at different current & phase advance values, each using only a single rotor 

position. Assumes that flux linkages are invariant with rotor position. 

• Saturation Model (Full Cycle) – characterises the machine saturation with FEA 

simulations at different current & phase advance values. For each point, the machine 

is simulated using the full electrical cycle and the flux linkage values are averaged. 

More details can be found in the Motor-CAD manual. 

For now we choose to build the coarse, single step saturation model and neglect the losses. 

While not an accurate way of calculating the machine performance across the full operating 

range or analysing the efficiency of the machine, this will very quickly give a good estimation 

of the peak performance. 

We choose the maximum model build speed and current to cover the full operating range that 

we will be using. 

Ensure that the Saturation Model checkbox is enabled and click Build Model to start building 

the model. The simulations should complete within 10-20 seconds. Note that, once the model 

is built, the Model Status table will be updated to show the details of the saved model. 
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Note that if any changes are made to the settings in the Model Build tab (e.g. loss model type 

is changed), the model must be rebuilt. If any changes are made to the machine geometry, 

winding or materials in the E-Magnetic or Thermal context, the Lab model also must be re-

built to reflect the changes. This will not be done automatically. 

 

Now that the model is built, we use the Calculation tab to set the operating conditions for the 

calculations. Note that any values on this page can be changed after the model build is 

complete. We use the following settings: 

Parameter Value Units 

DC Bus Voltage 375 V 

Maximum Modulation Index 1  

Operating Mode Motor  

Control Strategy Maximum Torque/Amp  

Mechanical Loss Neglect  
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For each point calculated in Lab, the current and phase advance are optimised to give the 

best operating conditions. Here, the user can select whether this optimisation should use the 

Maximum Torque/Amp (MTPA) or Maximum Efficiency (ME) control strategy. 

Note that the loss build factors are disabled since we are neglecting the losses. 

The Scaling options on the right-hand side of the page can be used to quickly adjust the 

model temperature or the number of turns/coil without rebuilding the model. We will leave 

these as their default values i.e. no scaling. 

 

We can now use the Electromagnetic tab to calculate the peak torque/speed curve. We set 

up the options as follows: 

Parameter Value Units 

Calculation Type Maximum torque/Speed 
Curve 

 

Speed: Maximum 10000 rpm 

Speed: Step 500 rpm 

Speed: Minimum 0 rpm 

Current: Maximum (Peak) 480 A 
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Click Calculate Emagnetic Performance, and the calculation should complete in a few 

seconds. The results are automatically shown in a new window. Previously calculated results 

can also be loaded at a later point with the Load Results Viewer button. 

 



 
 
 
 

 Page 46 of 132 

 

By default the viewer shows the torque vs speed graph, other values can be plotted by 

changing the X Axis or Y Axis dropdown, e.g. shaft power vs speed. The raw data can be 

viewed and exported under the Data tab, and the plot can be customised further under the 

Options tab. Exact values at any point can be found by clicking on the graph at the point of 

interest. 

 

 

ii. Efficiency Maps 

Save the file as Nissan_LEAF_4_Lab_EfficiencyMap.mot. The interface shows the E-

Magnetic context, use Model -> Lab to return to the Lab context. 

Before calculating the efficiency map, recall that we built the Lab model using the single step 

saturation model, neglecting the losses. While this is a very good way to get a fast estimation 

of the peak torque/speed performance, it will not give such accurate results for the efficiency 

map. We will therefore rebuild the model with more detail to get the best accuracy. 

On the Model Build -> Model Options tab, change the following settings: 

Parameter Value 

Model Type Saturation Model (Full Cycle) 

Model Resolution Fine 

Loss Model FEA Map 

 

When using the FEA map loss model it is always recommended to use the settings above for 

the saturation model. This allows the saturation model to be built using the same FEA 
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simulations as the loss model, reducing the calculation time and ensuring maximum model 

accuracy. 

A message will appear in the Message Display window: 

 

This is just informing us that the proximity losses (AC losses) will not be included in the Lab 

model since they have not been configured in the E-Magnetic model. This is fine for now – 

later on, in the Advanced E-Magnetic Modelling section, we will add proximity losses to our 

E-Magnetic model and then return to Lab to include them in the Lab model. 

 

 

 

Notice that some of the cells in the Model Status table are now highlighted in red. This 

indicates that the saved model build does not match the selected options, and the model must 

be rebuilt before any calculations can be performed. 

We keep the maximum model build speed and current the same as before. Ensure that both 

the Saturation Model and Loss Model checkboxes are enabled under Build, and click Build 

Model. This time the model build will take a little longer, this should complete within around 5 

minutes. 
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Now we navigate to the Electromagnetic tab in order to calculate the efficiency map. First, 

we will check the accuracy of our previous single-step model by re-calculating the peak 

torque/speed curve. With the same settings used previously, we click Calculate Emagnetic 

Performance to generate the peak curve. 
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We can see that the curve is very similar to the previous result, with a slightly lower torque 

throughout due to the inclusion of the loss model. 

 

We will now calculate the full efficiency map. Close the viewer and return to the Motor-CAD 

window. As well as including the copper, iron and magnet losses through FEA-based models, 

we can also defined the mechanical losses. These are typically comprised of a friction (e.g. 

bearing losses) and windage loss component. 

Mechanical losses are defined under the Calculation tab. For the LEAF motor, we have the 

following loss model: 

Parameter Value Units 

Calculation Type User Defined  

Friction Loss 150 W 

Friction Loss Exponent 1  

Windage Loss 0 W 

Windage Loss Exponent 2  

Reference Speed 10000 rpm 
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Under the Electromagnetic tab, set the following options: 

Parameter Value Units 

Calculation Type Efficiency Map  

Speed: Maximum 10000 rpm 

Speed: Step 250 rpm 

Speed: Minimum 500 rpm 

Current: Maximum (Peak) 480 A 

Current: No. of Increments 30  

Current: Minimum (Peak) 1  

Smooth Map Enabled  

 

The minimum speed/current, number of increments, and smooth map option are chosen to 

improve the visualisation of the efficiency map. 
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Click Calculate Emagnetic Performance to run the calculation. Again, the efficiency map is 

shown automatically. Other values can be plotted by selecting from the Y Axis and Z Axis 

dropdown, and the appearance of the plot (e.g. min/max values, number of contour lines) can 

be customised in the Options tab. 
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iii. Thermal Envelope 

The Thermal tab can be used to calculate the continuous thermal performance of the machine 

for steady-state or transient conditions. The resulting thermal envelope will show the maximum 

capability of the machine within the specified maximum temperatures. 

Since we have not yet configured the thermal model for the LEAF, we will return to the thermal 

envelope calculations later in the tutorial. 

 

iv. Drive Cycle 

The Lab module includes a vehicle model, based on a simple analysis of the forces acting on 

the vehicle, which can be used to calculate torque/speed points for a standard speed vs time 

driving cycle. Many standard test cycles are included, or users can specify a custom drive 

cycle with an external data file. 

For the Nissan LEAF, we have the following vehicle model parameters: 

Parameter Value Units 

Mass 1521 kg 

Rolling Resistance Coefficient 0.007  

Air Density 1.225 kg/m3 

Generating Torque Ratio 1  

Frontal Area 2.29 m2 

Drag Coefficient 0.28  

Final Drive Ratio 7.938  

Max. Torque Disabled  

Wheel Radius 0.3 m 

Mass Correction Factor 1.04  

Motoring Torque Ratio 1  

Max. Speed Disabled  

 

 

 

 

 

 



 
 
 
 

 Page 53 of 132 

 

 

We will simulate the US06 standard drive cycle. This is a standard testing cycle designed to 

test the real-world performance of vehicles, defined by a speed vs time profile. 

Parameter Value 

Drive Cycle Data Standard Drive Cycle 

Standard Drive Cycle US06 

 

 

 

Click Calculate Duty Cycle Performance to run the calculation. This should complete within 

about 2 minutes and by default the viewer shows the torque profile over the cycle. 
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The Analysis tab shows various useful parameters calculated over the cycle e.g. average 

efficiency, total input energy, total losses, etc. 
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Lab can also include the duty cycle operating points on the efficiency map. Since the duty 

cycle contains both motoring and generating points, we will first need to set the Operating 

Mode to Motor / Generator under the Calculation tab. 

 

 

We then return to the Electromagnetic tab and Calculate Emagnetic Performance again. 

When the results are shown, select the Show Drive Cycle option to display the operating 

points on the graph. 

 

The duty cycle loss values can be exported to the Thermal module in order to calculate the 

thermal performance over the cycle. We will come back to this step later, after we have 

configured the thermal model. 
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v. Single Operating Point 

The Operating Point tab allows the user to calculate the machine performance at a single 

point. At a given shaft speed, this finds the optimum operating conditions for the specified 

maximum current, torque or maximum temperatures, according to the chosen control strategy. 

This can be useful to quickly find the optimum current and phase advance values for a single 

operating point, and then investigate the machine performance more closely at this point using 

the E-Magnetic or Thermal modules. 

Set the following conditions: 

Parameter Value Units 

Definition Torque  

Speed 6000 rpm 

Torque 160 Nm 

Set Motor-CAD Emag Model Enabled  

Set Motor-CAD Thermal Model Disabled  

 

Click Calculate Operating Point to run the calculation, this should only take a moment, and 

the table will be updated with the results. 
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We can see that, with the MTPA (Maximum Torque per Amp) control strategy, the optimum 

point is found at 320 A supply current with a phase advance of 63.2 electrical degrees, giving 

a motor efficiency of 97.6%. Since we have selected the Set Motor-CAD Emag Model option, 

these operating conditions will be set automatically in the E-Magnetic module. We can now 

run the full transient FEA solution for this operating point to verify the results from the Lab 

model. 

Return to the E-Magnetic context using Model -> E-Magnetic from the main menu (or Ctrl+M). 

In the Calculation tab, we can see that the current, shaft speed and phase advance from the 

Lab operating point have been set here. 

Deselect all performance tests except for the Torque calculation and solve the model. 

 

Under Output Data -> E-Magnetics, we see that the shaft torque and efficiency found from 

the transient FEA solution are within 1.5% of the values calculated from the Lab model. We 

can view other detailed results for this operating point, for example flux plots, torque 

waveforms, harmonic analysis, loss distribution, etc. 
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6. Thermal Model 
The thermal model in Motor-CAD solves lumped parameter thermal networks in order to obtain 

the working temperatures of the machine. FEA thermal simulations can also be used in order 

to validate the lumped parameter model. 

Switch to the thermal context with Model -> Thermal or Ctrl+T (tip: a red background on the 

active tab indicates thermal context). Save the file as Nissan_LEAF_5_Thermal.mot. 

 

The following main tabs are available in the thermal context: 

Tab Description 

Geometry Define & view the machine geometry (radial, axial, 3d) 

Winding Define & view the stator winding 

Input Data Specify materials used in the model, define losses, define 
cooling systems, adjust advanced settings 

Calculation Specify the calculation options & run the calculations 

Temperatures View temperatures, lumped parameter thermal circuit, 2D 
thermal FEA, thermal model validation, design optimisation 

Output Data View numerical results 

Transient Graph View temperature & power results from transient simulations 
(only available when running transient calculation) 

Sensitivity Sensitivity analysis - vary input parameters and analyse effect 
on machine performance 

Scripting Create & run Visual Basic scripts in Motor-CAD 
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i. Geometry 

In the Thermal context, some additional geometry is now shown e.g. housing, mounting. This 

was hidden in the E-Magnetic context since it was not relevant to the electromagnetic model. 

We must now configure the thermal geometry parameters. 

Under Geometry -> Radial, set the following: 

Stator Parameter Value Units 

Housing Water Jacket (Spiral)  

Mounting Not Mounted  

Housing Dia 252 mm 

WJ Channel-Lam 10 mm 

WJ Channel Height 5 mm 

 

 

Recall: press Enter or click Redraw to update the drawing. 
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Under Geometry -> Axial, set the following: 

Radial Parameter Value Units 

Shaft Dia [F] 20 mm 

Shaft Dia [R] 20 mm 

Wdg Add [Outer F] 3 mm 

Wdg Add [Outer R] 3 mm 

 

Axial Parameter Value Units 

Endcap Length [F] 30 mm 

Endcap Length [R] 30 mm 

Endcap Thickness [F] 10 mm 

Endcap Thickness [R] 10 mm 

WJ Channel Width 30 mm 

WJ Channel Spacing 35 mm 
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ii. Winding Model 

The Winding -> Definition tab allows the configuration of the winding. 

The winding pattern is not shown since it is used in the electromagnetic model only and 

instead the individual position of the conductors can be customised under Winding -> 

Positions. Usually this is not necessary since Motor-CAD automatically places the 

conductors in the slot based on common manufacturing methods, but it can be useful for 

advanced users. The conductor positions are also used for thermal FEA simulations. 

The Motor-CAD model uses cuboids to represent the thermal behaviour of the winding within 

the lumped parameter network. The effective thermal conductivity and capacitance of each 

cuboid is calculate from the areas of copper, wire enamel and impregnation together with the 

material thermal properties. This allows an accurate, computationally efficient approximation 

of the thermal behaviour of the coils. A higher number of cuboids will increase the resolution 

of the model and is useful for machines with a non-uniform distribution of conductors or 

losses in the slot, but will also increase computation time in the thermal model. 

The cuboids used in the model are drawn on the cross-section when the Winding View is 

set to Cuboids. The number of cuboids and their dimensions can be customised by 

dragging the cuboid outlines using the mouse or under Input Data -> Settings -> Winding, 

for now we will use the default cuboid definition. 
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iii. Cooling System Definition 

The cooling setup is defined under Input Data -> Cooling, with options for individual cooling 

systems configured in separate tabs. 

The water jacket is the main cooling path for this machine. We have already defined the 

geometry of the water jacket, and now we need to configure the options and fluid flow 

through the jacket. 

Under Input Data -> Cooling, the Housing Water Jacket option is automatically enabled. 

This is required to provide the cooling through the water jacket. Here other cooling types can 

be enabled and general options for the motor environment are configured. 

There are several tutorials providing details of other cooling systems in Motor-CAD, these are 

available at https://www.motor-design.com/publications/tutorials/. 

We change the following: 

Parameter Value Units 

Ambient Temperature 65 °C 

 

All other parameters are left at their default values. Note that the shaft speed of 6000rpm has 

been inherited from the E-Magnetic model, based on the last simulation that we performed. 

 

https://www.motor-design.com/publications/tutorials/
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Housing Water Jacket 

We will now configure the settings for the water jacket. The flow rate will be defined in litres 

per minute instead of the using the SI unit of m3/s, so first we need to change the default unit 

using Defaults -> Units from the main menu. In the Units dialog, navigate to the Thermal tab 

and set the Volume Flow Rate unit to l/min. Click OK to save the new units. 

 

 

 

Under Input Data -> Housing Water Jacket -> Flow Options, we set the basic flow options 

for the water jacket: 

Parameter Value Units 

Flow Definition Constant Flow Rate  

Fluid Volume Flow Rate 6.5 l/min 
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Under Input Data -> Housing Water Jacket -> Fluid Flow, we define the fluid properties and 

other details of the flow through the water jacket: 

Parameter Value Units 

Inlet Temperature 65 °C 

Fluid Properties EGW 50/50  

Include Duct Wall Roughness Enabled  

Duct wall roughness 0.0025  

Active Cooling Only Enabled  

Non Spiral Ducts Enabled  

Endcap Cooling No Endcap Cooling  

Flow Direction Front -> Rear  

Calculate or Input Number Flow Channels Calculate  

Parallel Flow Paths 1  

Duct Wall Thickness 0 mm 
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Here we have chosen define the fluid properties based on values from the database. The 

cooling fluid used is EGW50/50, a mix of ethylene glycol and water commonly used as a 

vehicle coolant. Motor-CAD has a default database of fluids which can be used. Custom fluids 

can be added or the database properties viewed and modified from the Material Database -

> Fluids tab. For more information please refer to the Motor-CAD manual. 

 

 

The fluid flow table shows the calculated area, flow rate and pressure values for the housing 

water jacket as well as other thermal parameters. Under the Heat Transfer tab, a similar table 

gives the calculated heat transfer parameters. 

The final configuration of the water jacket can be visualised using cross-sectional or 3d views 

under the Geometry tab. 
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Interface Gaps 

Depending on manufacturing tolerances and the materials used the interface gaps between 

components can vary significantly. A larger interface gap will increase the thermal resistance 

between components and reduce the effectiveness of the cooling, which can result in large 

temperature rises in the machine. It is therefore important to configure the interface gaps in 

the thermal model in order to match the real-world conditions as closely as possible. 

Typical values of the air gaps between components are provided in Motor-CAD based on 

significant experience and real-world testing. This helps the user to set up the model 

accurately without an in-depth knowledge of manufacturing processes. 

For the Nissan LEAF most of the interface gaps automatically estimated by Motor-CAD are 

accurate. The gap between the stator lamination and the housing is better than average due 

to the manufacturing processes and so for the Stator Lam – Housing component we select 

Lamination-Metal – Good surface contact (0.01). 
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End Space Cooling 

The end space cooling can be configured under Input Data -> End Space. Several different 

endcap cooling options are available including ventilation and wafters. For this model we have 

no extra cooling in the end space so we leave the values at their defaults. 

The internal convection cooling from inside the endcaps (from end winding, rotor, endcaps, 

housing etc) is calculated automatically using empirical correlations based on experience and 

real-world testing. The calculated parameters for heat dissipation are shown in the table here 

and can be modified, though this is not usually necessary to achieve a good result.  

 

 

 

Advanced Cooling Options 

The Radiation and Natural Convection tabs under Input Data provide further options for 

customising the model. As with the end space cooling, coefficients and settings here are 

calculated based on extensive experience and testing, and typically do not need to be modified 

to achieve a good result. 
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iv. Materials Input 

The thermal properties of the materials can be configured in the Input Data -> Materials tab. 

The interface is similar to the electromagnetic model but here there are more components to 

configure. The total motor weight now includes the thermal components (e.g. housing, 

mounting, etc). 

 

 

 

v. Losses 

The machine losses are specified under the Input Data -> Losses -> Loss Models tab. The 

losses can be input directly for different components or the losses can be set automatically 

from the E-Magnetic or Lab modules based on the calculated values. There are several 

different loss models allowing for the losses to vary with speed and temperature. In this 

example we will use the results from the electromagnetic calculation to set the component 

losses. 

We will start by simulating a low-speed operating point, using the Lab module to find the 

operating conditions. Switch to the Lab context using Menu->Model -> Lab. 
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Navigate to the Operating Point tab and set the following parameters: 

Parameter Value Units 

Definition Torque  

Speed 1000 rpm 

Torque 200 Nm 

Set Motor-CAD Emag Model Enabled  

Set Motor-CAD Thermal Model Disabled  

 

Click Calculate Operating Point. Once the calculation is complete, the results will be shown 

and the calculated current & phase advance values will be set in the E-Magnetic model. Note 

that we could directly set the losses into the Thermal model here by enabling the Set Motor-

CAD Thermal Model checkbox, however here will demonstrate how the losses can be 

transferred from the E-Magnetic model. 
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Switch to the electromagnetic module using Menu->Model -> E-Magnetic.  

In the Calculation tab check that the operating conditions have been set correctly and 

ensure that the Torque calculation is selected to ensure an accurate loss calculation. Also 

set the E-Magnetics - Thermal Coupling option to E-Magnetics Losses -> Thermal so 

that the calculated loss values will be transferred automatically to the thermal model. 

Here we can also import the temperatures from the solved thermal model or run a coupled 

solution where the electromagnetic and thermal models are solved iteratively to converge 

the loss and temperature values.  
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Now Solve the model. Once solving is completed, check the loss values under Output Data 

-> Losses. 
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Return to the thermal model using Menu->Model -> Thermal and check the imported loss 

values under Losses -> Loss Models. 

Here we also set the following loss model options: 

Parameter Value Units 

Speed Dependent Losses Disabled  

Single value of Speed [REF] Disabled  

Copper Loss Variation with Temperature Enabled  

Winding Temperature at which Stator 
Copper Losses Input 

65 °C 

Losses Vary with Temperature & Load Disabled  

 

 

Note that there are no mechanical losses transferred as these are not currently calculated in 

the electromagnetic model. Friction losses can be input by the user, and windage losses can 

either be input directly or calculated automatically by Motor-CAD based on the fluid properties. 

For more details please refer to the Motor-CAD manual. 
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7. Thermal Analysis 
Based on the input geometry, losses and model settings Motor-CAD creates a 3D lumped 

parameter circuit model to characterise the thermal behaviour of the machine. Each 

component is represented with a thermal resistance and capacitance. Losses are 

represented as power sources, and power is dissipated to the ambient node by the cooling 

systems. By solving this equivalent thermal circuit Motor-CAD can accurately estimate the 

temperatures in each part of the machine. 

i. Steady-State Calculation 

Under the Calculation tab, we make sure the Calculation Type is set to Steady State and 

click Solve Thermal Model or press Ctrl+R to run the calculation. 
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When solving is complete Motor-CAD will automatically show the results. Under the 

Temperatures -> Radial and Temperatures -> Axial tabs we can view the final machine 

temperatures on the radial/axial cross-section drawings. 

Throughout the thermal module the colours used to represent components in the model match 

those used in the cross-section drawings. 
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ii. Lumped Parameter Thermal Model 

As described above Motor-CAD’s thermal model is based on creating and solving a lumped 

parameter thermal network. The Temperatures -> Schematic -> Overview tab shows a 

schematic overview of the solved network.  

From top to bottom, the schematic is laid out as follows: the shaft at the bottom of the 

schematic with the bearings and the endcaps on both sides, left and right. Following in the 

centre of the schematic and connected to the shaft is the rotor lamination, the interior 

magnets, the rotor again, the airgap, the winding (with the active part and the end-windings), 

the stator lamination, the housing with the water jacket as a heat extractor and the ambient 

surrounding the model with natural convection and radiation. 

The colours used in the schematic match those used in the cross-sectional and 3d drawings. 
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The complete thermal network can be viewed under Temperatures -> Schematic -> Detail 

-> Circuit. This is similar to the schematic view shown above but provides more detail on the 

complete thermal circuit, including all connections between the components. 

The visualisation of the names and values of thermal resistances, temperatures, power 

sources and nodes can be customised using the Plot Options on the left hand side. Here we 

select the following options to simplify the view: 

Parameter Value 

Resistance No Display 

Power Source No Display 

Node Label 

Grid No Display 

 

 

Here we can also understand the cuboidal model used for the stator windings, shown in yellow 

in the centre of the circuit. We have two rows of winding nodes, C1 (cuboid 1) and C2 (cuboid 

2), with the front end winding nodes on the left and rear end winding nodes on the right. 
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The Output Data sheets provide detailed results from the thermal simulation, including 

temperatures, heat transfer coefficients, thermal resistances, etc. For more information on any 

output parameters, please refer to the Motor-CAD manual. 
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iii. Simple Transient 

We can also use the Motor-CAD model to simulate the machine temperatures during a 

thermal transient. There are two ways to simulate a transient in Motor-CAD – either with a 

simple transient, where the operating point is constant throughout the transient period or with 

a duty-cycle analysis where the operating conditions (e.g. torque, speed, losses) vary 

throughout the cycle. First we will simulate a simple transient case. 

We define the transient under Input Data -> Duty Cycle -> Settings as follows: 

Parameter Value Units 

Transient Calculation Type Simple Transient  

Point Storage Reduction 1  

Transient Period 7200 seconds 

Number Points 20  

Change in Tambient 0 °C 

Initial Transient Temperatures Whole machine at 
specified temperature 

 

Machine Temperature 60 °C 
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We then go to the Calculation tab, set the Calculation Type to Transient and then Solve 

the model. 

 

During solving, the transient progress bar shows the progress of the simulation. By default the 

results are not shown during the solution for speed, but can be displayed using the options 

here. 
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When solving is completed, the results are plotted against time in the Transient Graph tab. 

By default the temperature and power values are plotted for common nodes of interest. Using 

the Setup tab, the graphs can be customised to display the results for any nodes. The chart 

titles, axis limits and series options can also be changed. The Data tab provides the raw data 

for viewing or exporting, and the Graphs tab displays the plots. 

In the Temperatures graph, we see the temperatures rapidly increase at the start of the 

transient and then converge towards their steady-state values. Note that the colours in the 

graph match those used in the cross-section drawings and the thermal network schematics. 
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The Power graph shows the power dissipated in the motor over the transient period. We see 

that the losses in the stator copper increase over time due to the use of the Copper Losses 

Vary with Temperature model we enabled in the Input Data -> Losses tab (section 6.v.). 

The power dissipated in all other nodes is constant with temperature and so do not change 

over time. 
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The Temperatures -> Schematic/Radial/Axial and Output Data tabs show the final values 

at the end of the transient calculation. 
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iv. Duty Cycle with Lab 

We will now simulate a more complex duty cycle. Under Input Data -> Duty Cycle -> 

Settings, we set the following: 

Parameter Value Units 

Transient Calculation Type Duty-Cycle Analysis  

Point Storage Reduction 1  

Change in Tambient 0 °C 

Number of Cycles 1  

Initial Transient Temperatures Ambient Temperature  
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The duty cycle values (e.g. losses, shaft speed at each point) are defined under Input Data -

> Duty Cycle -> Definition. In the thermal model, the duty cycle is typically defined by loss & 

shaft speed values vs time. 

 

 

However, when designing a machine it is more usual to define the duty cycle with a 

torque/speed profile over time. From this an electromagnetic model is used to find the power 

losses over time, and then this defines the thermal duty cycle. Here the Lab module is a 

valuable tool since we can very quickly calculate losses over a duty cycle and export the 

values to the thermal model. 
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Switch to the Lab module using Menu->Model -> Lab and navigate to the Duty Cycle tab. 

Recall that we previously set up the vehicle model for the LEAF with the US06 duty cycle. 

Check the settings are correct and click Calculate Duty Cycle Performance to run the 

calculation. 

Once the calculation is complete, click Export Duty Cycle To Thermal Model. This will export 

the calculated loss data from the duty cycle to the thermal model. This will be confirmed by a 

message. 
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Now return to the thermal model and check the duty cycle data under Input Data -> Duty 

Cycle -> Definition. 
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Go to the Calculation tab, check that the Calculation Type is set to Transient and Solve the 

thermal model. 
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We are particularly interested in the stator winding and magnet temperatures. Under 

Transient Graph -> Setup -> Temperature Graph Setup, customise the transient graph to 

show only the Ambient, Magnet, Winding (Average) and Winding (Hotspot) nodes (the 

Select/Deselect all nodes checkbox can be useful here). Deselect the Draw Points option. 
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Furthermore, more than one cycle of the duty cycle can be simulated. Change the Number 

of Cycles to 5 under Input Data -> Duty Cycle -> Settings, and then run the calculation 

again from the Calculation tab. 
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Note that, when saving the file, the following message appears: 

 

For duty cycles with fewer than 500 periods, Motor-CAD will save the duty cycle data in the 

.mot file. Otherwise, the data is automatically saved to a separate external file to prevent the 

size of the .mot file from growing too large. Here a location must be selected for saving the 

external file. 
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v. Continuous Thermal Performance with Lab 

The thermal envelope gives the torque and power that the machine can produce continuously 

at different rotating speeds for a given value of maximum working temperature. The Lab 

module calculates the power losses in the machine using the FEA map model that we have 

built, and then uses the thermal model to iteratively find the maximum electromagnetic 

performance at the specified temperatures. 

Here we will calculate the continuous thermal envelope for steady-state conditions. Switch to 

the Lab model and go to the Thermal tab. Set the following: 

Parameter Value Units 

Thermal Map Type Envelope  

Thermal Calculation Steady State  

Thermal Limit Stator Winding + 
Magnet 

 

Maximum Winding Node Average  

Initial Current Estimate (Peak) 240 A 

Speed: Maximum 10000 rpm 

Speed: Step 500 rpm 

Speed: Minimum 200 rpm 

Maximum Temperature: Stator 
Winding 

160 °C 

Maximum Temperature: Magnet 140 °C 

Limit on Max. Current Disabled  
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Click Calculate Thermal Performance to run the calculation. Note that, since the 

electromagnetic and thermal calculations must be iterated to find the optimum working point 

at maximum temperature, this calculation can take some time. The calculation can also be 

sensitive to the Initial Current Estimate so it is advised to ensure that a sensible value is 

used; typically ½ of the model build current is appropriate. 

By comparing to the peak torque/speed curve calculated previously (see section 5), we can 

see that the machine cannot operate continuously at peak performance within the thermal 

limits. 

 

 

By plotting Stator Winding Temp Average and Magnet Temp on the Y Axis, we can see 

that the machine performance is constrained by the winding temperature at low speeds, and 

by the magnet temperature at high speeds. 
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The thermal capability of the machine can also be calculated for a transient period, using either 

a simple transient or complex duty cycle. This is done by configuring the transient in the 

Thermal model and then setting the Thermal Calculation to Transient. It should be noted 

that this calculation can take a long time and may be infeasible if the transient thermal 

calculation takes too long. It is recommended to use the simplest transient calculation possible 

and optimise the number of points to maintain a reasonable calculation time. 
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8. Advanced E-Magnetic Modelling 
We will now demonstrate some of the more advanced features of Motor-CAD’s 

electromagnetic model. Save the file as Nissan_LEAF_6_Advanced.mot and switch to the 

E-Magnetic model. 

i. Custom DXF Geometry 

The 2D FEA using Motor-CAD’s parameterised geometric model gives a very fast estimation 

of the electromagnetic performance and generally gives accurate prediction of average torque 

and power loss. However, sometimes the precise machine geometry cannot be reproduced 

using the parameter model, and simulating the exact geometry including e.g. flux barriers can 

provide more accurate prediction of torque ripple. 

For geometries which cannot be reproduced exactly with the parameter model, dxf files can 

be imported into Motor-CAD for simulation. There is a detailed tutorial which describes the 

requirements for an imported DXF and the procedure for importing the geometry, available at 

https://www.motor-design.com/publications/tutorials/. 

The Nissan LEAF motor has some minor differences to the model we have created in Motor-

CAD, and we will now import the DXF geometry. We open the DXF Import dialog by selecting 

File -> Geometry Import from the main menu. Using the file open button, we select the 

attached file leaf_dxf.dxf and select the following settings: 

Parameter Value Units 

View Radial  

Scale 1.0  

Rotation 22.5 ° 

Auto Centre Disabled  

x offset 0.0 mm 

y offset 0.0 mm 

 

 

Click Display to show the DXF outline on the Geometry -> Radial cross-section, and then 

close the dialog. 

 

https://www.motor-design.com/publications/tutorials/
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When using imported DXF geometry, it is important that the parameterised Motor-CAD model 

matches the DXF geometry as closely as possible. This view can be used to modify the model 

parameters and check how well the geometry matches. The most important parameters are: 

• Stator slot number, shape and dimensions 

• Pole number, rotor type and dimensions 

• Outer and bore diameter of the stator lamination 

• Airgap thickness 

• Shaft and shaft hole diameters (if any) 

• Number, size and position of ducts in both stator and rotor 

• Sleeve/banding definition 

In particular, the airgap thickness and location simulated in the FEA model will be defined 

based on the Motor-CAD parameters rather than the DXF, so this must match as closely as 

possible for a good result. 
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For the FEA simulation, the DXF geometry needs to be activated in the FEA Editor. Under the 

E-Magnetics -> FEA Editor tab, set the following geometry options: 

Parameter Value 

Use DXF E-Magnetic Enabled 

Use DXF as Entire Machine Disabled 

Show Airgap Enabled 

Display DXF Errors Enabled 

 

 

Note that the geometry shown is now based on the imported DXF rather than the Motor-CAD 

template geometry. We now need to match up the FEA regions to the imported DXF geometry. 

All regions which have a complete boundary should be defined by placing a region identifier 

within the boundary. The regions are indicated by coloured rectangles or, in the case of 

permanent magnets, by an arrow indicating the magnetisation direction. Clicking on a region 

selects it and highlights its entry in the region table, and vice versa. 
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We notice immediately that there are some Region Warnings indicating that we have 

duplicate regions defined. For the first warning click on the warning text to highlight the 

problematic region in the table and the drawing. 

 

Now that we know where the problem is we can zoom in to inspect the region more closely. 

Zoom in by drawing a rectangle with the left mouse button over the area of interest or zoom 

out by clicking with the left mouse button on the drawing. We can pan the drawing by holding 

down the right mouse button and dragging the view. 

By zooming in on the region, we see that the point defining the rotor air region at the end of 

the magnet is incorrectly placed in the rotor lamination. This is because the region markers 

have been placed based on the Motor-CAD parameterised geometry, and the custom shape 

of this region in the DXF does not quite match. We need to move this region marker inside the 

enclosed air region. We do this by selecting the region with the left mouse button and using 

drag and drop to place it in the correct location. It is generally recommended to place region 

markers in the centre of the region, as region markers placed too close to boundary lines may 

generate warnings or errors. 
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When we move the region, the following message appears: 

 

This is warning that we are about to start using custom regions for the FEA simulation instead 

of the default regions generated by Motor-CAD. We click Yes to continue with the region 

editing and notice that the Use Custom E-Magnetic Regions checkbox has been 

automatically enabled. 
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Now that the region has been moved to the correct position, the first warning has disappeared. 

We repeat the process for the second warning, which refers to the air region at the end of 

another magnet, so that there are no remaining warnings. We now visually check all regions 

to make sure they are correct. 
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We now go to the Calculation page. In order to compare with the FEA calculations performed 

in section 4 without the DXF geometry, we set the following: 

Parameter Value Units 

Shaft Speed 3000 RPM 

Peak Current 480 A 

Phase Advance 45 Elec deg 

 

We enable only the Torque, Back EMF and Cogging Torque calculations and Solve the 

model. 
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When solving is completed we can view the results. Under E-Magnetics -> FEA, we see that 

now the DXF geometry has been used for the simulation. 
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We can check the impact of the geometry customisation on the machine performance in the 

Graphs. 

 

 



 
 
 
 

 Page 106 of 132 
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ii. Calculation Settings 

Motor-CAD provides advanced settings for the electromagnetic calculations including 

simulation options and manufacturing factors in Input Data -> Settings. Here we will use 

some of these settings to improve the accuracy of the LEAF model. Further information on 

all settings can be found in the Motor-CAD manual. 

Loss Build Factors 

The measured power loss in steel materials is often greater than the characterised loss 

density given in the datasheets due to the manufacturing processes used. These effects are 

considered in the model by the use of build factors. The required build factor will depend on 

many factors but typically will be between 1 to 3. Build factors are defined under the Input 

Data -> Settings -> Losses -> General tab. 

For the 30DH steel used in the LEAF motor we will use: 

Parameter Value 

Stator Build Factor 1.5 

Rotor Build Factor 1.5 

 

Build factors are also available for magnet and shaft losses but are not required for this model. 
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Manufacturing Factors 

In the case of complex geometries or external factors the resistance, inductance or flux 

densities may need to be adjusted. These factors are typically calibrated with experimental 

test data and can be found under Input Data -> Settings -> E-Magnetics. 
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Drive Settings 

Details of the drive control can be configured under Input Data -> Settings -> Drive. For 

sine wave driven machines, such as the LEAF, it is important to specify the correct Sine 

Drive Modulation strategy to enable Motor-CAD to calculate the voltage available from the 

inverter. For this model Circle tracking is used. 

Here it is also possible to define an LC filter circuit at the input of the machine. For square 

wave driven machines or other machine types (e.g. SRM), this page also provides more 

sophisticated drive options. 
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Calculation Settings 

The Input Data -> Settings -> Calculation tab is used to configure the settings used in the 

FEA simulations. 

The Mesh Control options allow the user to change the number of points used for the mesh 

in the airgap, as well as the maximum mesh element length in the stator, rotor or magnet. 

Normally the default values work well and these should only be changed if there are 

problems meshing the model. 

Motor-CAD automatically uses symmetry to reduce the size of the model solved in the FEA, 

enabling a significant reduction in calculation time without loss of accuracy. The Model Size 

settings can be modified if the user wishes to simulate the full machine or to force Motor-

CAD to use a particular symmetry factor. The time taken to simulate the model reduces with 

the square of the symmetry factor, so that simulating a ½ machine will take ¼ of the time to 

solve compared to a full machine. 

The Magnetic Solver option allows the user to perform multi-static FEA simulations instead 

of using the full transient solver to reduce the calculation time. This can be useful for 

optimisation routines however it should be noted that the full transient solver is required for 

an accurate estimation of losses. 
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Graph Display Settings 

The Input Data -> Settings -> Graphs tab is used to configure the display of graphs in 

Motor-CAD. 

In Motor-CAD, for a sine wave driven BPM machine, we have 3 standard torque calculation 

methods: Maxwell Stress (MS), Virtual Work (VW) and DQ axis analytic torque (DQ). Details 

of the methods can be found in the Motor-CAD manual. As default Motor-CAD displays the 

torque values from the Virtual Work method, however it can be useful to compare the torque 

values calculated using the different methods.  
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iii. Proximity Losses 

The losses in the stator winding due to proximity and skin effects (commonly known as AC 

losses) can be estimated in Motor-CAD using two different methods: Hybrid FEA or Full FEA. 

The Hybrid FEA method uses the flux density levels in the slot to estimate the proximity 

losses. The flux densities are taken from the FEA simulation based on the cuboid positions, 

and proximity losses are calculated using analytic equations for each cuboid. It is not 

possible to account for skin depth effects using this method so particular care must be taken 

with machines operating at high speeds or with large conductors where these effects can be 

significant. 

In the Full FEA method individual conductors are simulated in a single slot and the induced 

eddy currents are calculated. The Full FEA method is more accurate, but the calculations 

take longer, so the choice of method depends on whether the model accuracy or calculation 

speed is the higher priority. 

There is a more detailed tutorial on AC loss calculations in Motor-CAD, available at 

https://www.motor-design.com/publications/tutorials/. 

Under Input Data -> Settings -> Losses -> Proximity, set the following: 

Parameter Value 

Proximity Loss Model Hybrid FEA 

Include Bundle Effect Enabled 

Bundle Aspect Ratio 1 

Cuboid Size Skewed distribution 

Number of Cuboids 6 

 

 

https://www.motor-design.com/publications/tutorials/
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The proximity losses are typically larger towards the slot opening due to the magnetic field 

generated by the rotor. Selecting the Skewed distribution option allows Motor-CAD to 

increase the number of cuboids around the slot opening, increasing the resolution in this 

region and hence improving the accuracy of the proximity loss calculation. 

Note that the bundle aspect ratio describes the height:width ratio of the conductor bundle. It 

is important to ensure that this value is accurate. 

In the Winding -> Definition tab, set the Winding View to Cuboids in order to visualise the 

cuboids defined by Motor-CAD for calculation of the proximity losses. We can see that the 

cuboids placed at the slot opening are smaller than those at the bottom of the slot. Note that 

the cuboids are numbered from the bottom of the slot down towards the opening. 

 

 

When using the electromagnetic model only, increasing the number of cuboids does not affect 

the calculation time and therefore it would be recommended to use 20 cuboids (same as the 

number of strands in hand) for increased accuracy. However, in the thermal model, increasing 

the number of cuboids will increase the complexity of the thermal circuit and therefore the 

amount of time taken to solve the model. We have therefore chosen 6 cuboids as a 

compromise between the accuracy and thermal calculation time.  
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We will now solve the electromagnetic model to see the resulting losses. AC effects are more 

significant at higher speeds, so we therefore choose a high-speed operating point. We choose 

the following: 

Parameter Value Units 

Shaft Speed 6000 rpm 

Peak Current 200 A 

Phase Advance 65 Elec deg 

 

Ensure that the Torque calculation is enabled and Solve the model. 
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Once the solving is completed, we can see the calculated losses under the Output Data -> 

Losses tab. In the left-hand table, the total AC Copper Loss is reported at the top of the 

table. We can scroll down to see full details of the calculated AC losses, including a 

breakdown of the losses in individual cuboids. 
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We can see the impact of the AC losses, including the distribution across the cuboids, on the 

machine temperatures by solving the thermal model for this operating point. In the Calculation 

tab, we set EMagnetics - Thermal Coupling to E-Magnetics Losses -> Thermal. This 

transfers the calculated losses into the thermal model – note that we do not need to solve the 

e-magnetic model again. 
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Now switch to the thermal model and view the losses under Input Data -> Losses -> Loss 

Models. The AC losses are labelled as Loss [Stator Copper Freq Comp]. 

 

We can see the AC loss distribution over the cuboids under Input Data -> Settings -> Losses 

-> Proximity. This distribution is taken from the e-magnetic results. 
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We now go to the Calculation tab, set the Calculation Type to Steady State and solve the 

thermal model. 

 

In the OutputData->Temperatures -> Winding Temperature Graph tab we can see the 

temperature distribution from the slot opening to slot bottom. For each cuboid we have the 

temperature in the winding and in the stator tooth. We can see the temperature increasing 

towards the slot opening. 
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In the Temperatures -> Schematic -> Detail -> Circuit tab, we can see the distribution of the 

losses in the thermal network. Note that we have used the Plot Options to display only the 

Power Source Value on the drawing. 
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Note: now that we have included the proximity losses in the model, the thermal duty cycle data 

previously saved to an external file is no longer valid since it will not contain the proximity loss 

data. We therefore need to remove the external duty cycle data file that we saved in section 

7.iv. Under Input Data -> Duty Cycle -> Definition, use the Clear Data button to clear the 

external duty cycle data. 
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iv. Lab Model with Advanced E-Magnetic Model 

Now we need to re-build the Lab model taking into account the new geometry. Switch to the 

Lab context and go to the Model Build -> Model Options tab. Note that, by using the FEA 

Map option for the Loss Model, the AC losses are automatically included if they are enabled 

in the electromagnetic model. 

Check the settings, ensure that both the Saturation Model and Loss Model build options are 

enabled, and click Build Model. 

 

 

 

 

 

 

 

 

 

 



 
 
 
 

 Page 122 of 132 

 

Under the Calculation tab, set the Operating Mode to Motor and check the other settings. 

Notice that the Iron Loss Build Factors specified in the E-Magnetic model are also used here 

 

 

Under the Electromagnetic tab, we check the settings and click Calculate Emagnetic 

Performance to generate the efficiency map. 
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9. Advanced Thermal Modelling 
We will now demonstrate some of the more advanced features of Motor-CAD’s thermal model. 

Save the file with Menu->File -> Save and switch to the thermal model Menu -> Model -> 

Thermal. 

i. Slot Conduction and Winding Model Validation 

The cuboidal model used in Motor-CAD for the heat transfer calculation within the slot can be 

calibrated with FEA simulations. The calibration of the cuboidal model consists in isolating the 

active winding from the end-effects, configuring power loss only in the active winding and 

comparing the thermal results of the model to the FEA results. 

Under Input Data -> Losses -> Loss Models, we set losses only in the stator copper: 

Component Loss Units 

Loss [Stator Copper] 5000 W 

All other components 0 W 

 

We also disable all loss variation with speed, temperature and load. This enables accurate 

calibration of the model at a single operating point. 
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In the Calculation tab, we set the following: 

Parameter Value 

Calculation Type Steady State 

Model Size Full Model 

Model Type 2d model for FEA calibration 

E-Magnetics - Thermal Coupling No coupling 

 

 

Now solve the model. We notice that the Motor-CAD window caption has been changed to 

indicate the model is in 2D FEA calibration mode. 
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By using the 2D model Motor-CAD neglects thermal connections along the axial length of the 

machine between the windings, stator and rotor. We can see in the Temperatures -> 

Schematic -> Detail -> Circuit tab that the cuboidal elements that represent the active 

winding are only connected to the rotor and the stator, therefore neglecting the end space 

effects. 
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Now we have solved the full thermal circuit using the 2D Fea calibration model we can perform 

a thermal simulation using thermal FEA. This is solved in the Temperatures -> FEA tab. Set 

the Area Select to Stator and click Solve Slot FEA. 

The plot can be customised using the options in the left hand panel, and a comparison is 

reported between the FEA and analytic model for the minimum, average and maximum 

winding temperatures. When the mouse is hovered over the plot, the status bar displays 

detailed information about the point under the mouse cursor, including region name, 

temperature and losses. 

 

The results usually are well matched between the FEA results and the analytic model. In this 

example, the difference in the average temperatures is less than 2°C. 

Sometimes the predicted temperature can be different due to the random position of the 

conductors inside the slot. In this case the size of the cuboids could be updated in order to 

modify the ratio of copper and impregnation. This would change the thermal conductivity of 

the winding. However this FEA solution is only valid for the position of the conductors shown 

and often the conductor positions are not exactly known. 

After the 2D calibration has been performed and we are happy with the results, we restore the 

full 3D model by setting the Model Type to 3D model under the Calculation tab. 
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ii. Custom Thermal Tests 

As well as simulating standard testing cycles, Lab can calculate the machine performance 

over custom duty cycles based on external data files provided by the user. Once the 

electromagnetic performance has been calculated in Lab, we can then export the calculated 

loss values to the thermal model to simulate the thermal behaviour over the cycle. We can 

use this functionality to simulate a thermal test carried out on the LEAF motor. 

The graph below shows the results from a thermal test performed under laboratory conditions 

on the Nissan LEAF machine. The test lasted for 3 hours and the machine was operated with 

different loads while rotating at 7000rpm. 

 

  

 

To simulate this test in Motor-CAD, we generate a text file containing the time, torque and 

speed values for the test. The values must be in SI units (seconds, Nm, rpm) and the file must 

contain only the numerical values. 

• Start at 0 Nm (0 kW) 

• 1 hour at 68.2 Nm (50 kW) 

• 30 mins at 81.85 Nm (60 kW) 

• 30 mins at 95.49 Nm (70 kW) 

• 1 hour at 109.1 Nm (80 kW) 

• Finish at 0 Nm (0 kW)  
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Go to the Duty Cycle tab in the Lab context and set the following: 

Parameter Value 

Drive Cycle Data External Data 

Data Type Time(s), Torque(Nm), Speed (rpm) 

 

Notice that the vehicle model input is now disabled since the vehicle model is not used in this 

calculation. Use the Load button to select the custom duty cycle file, and then click Calculate 

Duty Cycle Performance. 

 

The resulting torque profile matches the values we have requested. 
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We now close the viewer and click Export Duty to Thermal Model to export the power loss, 

speed and time values to the thermal model. 

We now return to the thermal model Menu -> Model - > Thermal and check the imported duty 

cycle under Input Data -> Duty Cycle -> Definition. 

 

Under Input Data -> Duty Cycle -> Settings, we reset the Number of Cycles back to 1, 

since the cycle is only run once for the test. 
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Under the Calculation tab, we set the Calculation Type to Transient and Solve the thermal 

model. 

When solving is completed, we customise the graph under Transient Graph -> Setup -> 

Temperature Graph Setup to hide the shaft nodes and disable the Draw Points option, and 

then view the resulting temperature graph. 
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10. Conclusions 
We have modelled the brushless permanent magnet (BPM) machine of the 2012 Nissan LEAF 

using Motor-CAD’s E-Magnetic, Thermal and Lab modules. We have obtained detailed 

electromagnetic and thermal performance results for a single operating point, efficiency maps 

showing the performance across the full operating range and combined electromagnetic and 

thermal performance for a complex drive cycle. 

For further information on using Motor-CAD, please refer to the Motor-CAD manual under 

Help -> Manual in Motor-CAD, or see other software tutorials at https://www.motor-

design.com/publications/tutorials/. 

https://www.motor-design.com/publications/tutorials/
https://www.motor-design.com/publications/tutorials/

